Automattic et l’équipe AMP de Google ont publié 0.7 Release Candidate 1 (RC1) du plugin AMP pour WordPress. Cette RC1 est une version majeure qui contient de nouvelles fonctionnalités significatives.

Cette version ajoute la prise en charge AMP native pour tous les widgets, les « embeds » et commentaires par défaut. Les notifications seront déclenchées pour les publications qui contiennent du contenu avec des erreurs de validation ou si vous utilisez un thème ou un plug-in qui ajoute un balisage AMP non valide.

Alors que les versions antérieures d’AMP affichaient du contenu d’une manière différente du thème d’un site, 0.7 crée une expérience native. Par exemple, si vous visitez le site de démonstration du thème WordPress AMP Conf sur un iPhone 7, le site est exactement le même. Comme vous pouvez le voir dans l’image ci-dessous, vous ne pouvez pas dire qu’il fonctionne AMP.

Bien que le code RC1 de ce plugin soit à priori « stable ». On vous conseille vivement de ne pas utiliser la version RC1 sur un site en production. Vous devrez donc continuer à préférer la version 0.6.1 qui est la version officiellement stable pour un site en production. On « enfonce des portes ouvertes » en disant de ne pas utiliser des versions RC des plugins sur vos sites en productions mais parfois ça va mieux en le disant 🙂

AMP pour WordPress : 0.7 RC 1 Released
Moyenne des notes : 5 (100%) 1 vote