C’est maintenant officiel, la prochaine version majeure de WordPress ne supportera pas Microsoft Internet explorer versions 8,9 et 10. C’est Matt Mullenweg qu’il l’a lui-même annoncé après avoir eu de longues discussions sur le support des navigateurs web par WordPress.

Cela n’a rien d’étonnant dans la mesure où Microsoft lui-même ne supporte plus ces versions depuis janvier 2016. Selon plusieurs sites internet la part de ces versions d’Internet explorer dans les consultations de sites web est tombée à moins de 3%. Quoi qu’il en soit cela va soulager un paquet de développeur, mais il serait bon de l’annoncer à vos clients pour qu’ils ne soient pas surpris.

À noter que cette décision était un choix évident dans la mesure où l’éditeur TinyMCE qui sera inclus dans sa prochaine version dans WordPress 4.8 lui non plus ne supportera pas ces versions d’Internet Explorer.

Pas de panique non plus cela ne veut pas dire que tout va se casser à l’arrivée de cette version de WordPress. Juste que rien ne sera fait pour tester et donc valider l’utilisation de IE dans ce contexte.

Il n’y a pas encore de date annoncée pour la V4.8 de WordPress. Cela laisse donc encore du temps pour s’affoler et contacter tout vos clients 🙂