WordPress 4.9.5 est maintenant disponible. Ceci est une version de sécurité et de maintenance pour toutes les versions depuis WordPress 3.7. Nous vous encourageons vivement à mettre à jour vos sites immédiatement. Pour ceux qui souhaiteraient le faire de manière automatique lors des prochaines mise à jour de WordPress, nous vous engageons à lire cet article.

WordPress versions 4.9.4 et antérieures sont affectées par trois problèmes de sécurité. Dans le cadre de l’engagement continu de l’équipe WordPress de base à renforcer la sécurité, les corrections suivantes ont été implémentées en 4.9.5:

  • Ne traitez pas localhost comme le même hôte par défaut
  • Utilisez les redirections sécurisées lors de la redirection de la page de connexion si SSL est forcé
  • Assurez-vous que la chaîne de version est correctement échappée pour une utilisation dans les balises de générateur.

Vingt-cinq autres bugs ont été corrigés dans WordPress 4.9.5. Particulièrement de note étaient:

  • Les styles précédents sur les shortcodes de légende ont été restaurés
  • Le recadrage sur les appareils à écran tactile est maintenant supporté
  • Une variété de chaînes telles que les messages d’erreur ont été mises à jour pour plus de clarté
  • La position d’un espace réservé pour la pièce jointe lors des téléchargements a été corrigée
  • La fonctionnalité nonce personnalisée dans le client JavaScript API REST a été rendue cohérente dans la base de code
  • Compatibilité améliorée avec PHP 7.2.
WordPress 4.9.5 mise à jour de maintenance et de sécurité
Moyenne des notes : 5 (100%) 1 vote